Logo BeatPass™ - Service Status

Temporary outage

  • Resolved
    Services now back online.
  • Identified
    Confirmed service will be restored at 10:35PM EST.
  • Investigating
    Due to a situation out of our control, BP will be unavailable for a short while. We do expect the platform to be back online before midnight EST.